Jump to content

fishnfool

Lifetime Premium Member
  • Content Count

    572
  • Joined

  • Last visited

  • Days Won

    5

fishnfool last won the day on March 27

fishnfool had the most liked content!

Community Reputation

289 Excellent

About fishnfool

  • Birthday 07/27/1954

Profile Information

  • Gender
    Male
  • Location
    Greenback

Recent Profile Visitors

1,235 profile views
  1. Good deal. Thought you got a whole new rig 2-3 years ago?
  2. Thanks Tubejig. The oil is draining from under the cowling and dripping into the splash well but I can't figure out where it's coming from.
  3. I have a 1995 Ranger R70 Sport with a 115 Johnson Fast Strike. The motor runs great (~44 mph with 2 in the boat with all our gear) but seems to smoke more than typical and I notice some oil drains out of it into the splash well while sitting in the garage. Also notice a strong fuel/oil odor in the garage for the first few hours after parking it. With it running so well I hate to have anything done to it but wonder what is causing this and if I should be concerned about any of it. Any thoughts/suggestions would be appreciated.
  4. Thanks guys. Sent from my iPhone using Tapatalk
  5. I put a Motorguide Pro Series 75 on my Ranger R70 Sport last year replacing a 35 lb unit that was under powered and noisy. Now I have plenty of power but the mounting bracket still flexes and pops (very annoying) even at the lowest power setting. The unit is currently mounted directly to the boat. I've seen quick release mounting bases but don't know if that would fix the flexing/popping. Does anyone have any suggestions on how to eliminate the flex/popping noise?
  6. The trolling motor is typically running I think. Transducer cable isn't routed with other cables though. Other unit is usually on, haven't tried front unit with main unit off. No room for 4th battery....guess I just deal with it. Sent from my iPhone using Tapatalk
  7. It's connected to big motor starting battery along with another depth finder and other accessories on the boat (aerator bilge pump lights). Sent from my iPhone using Tapatalk
  8. Yes seems to be frequent at 20-30' depths not as frequent in shallower or deeper water. Transducer is on trolling motor foot. Sent from my iPhone using Tapatalk
  9. BUMP Sent from my iPhone using Tapatalk
  10. Any ideas on what's causing these lines? Sent from my iPhone using Tapatalk
  11. Excellent work! Crappie better watch out now. Sent from my iPhone using Tapatalk
  12. Could be wrong but guessing it would be better to buy new. Anything I've ever thought about recovering ended up nearly as expensive as buying the item. Sent from my iPhone using Tapatalk
  13. Glad you got it running without breaking the bank.
×
×
  • Create New...